Size: 2011
Comment:
|
Size: 1413
Comment:
|
Deletions are marked like this. | Additions are marked like this. |
Line 1: | Line 1: |
= FreeBSD Setup = | = FreeBSD = |
Line 15: | Line 15: |
While ARM's aarch64 (a.k.a. armv8) is not a Tier 1 supported platform, [[https://wiki.freebsd.org/action/show/arm/Raspberry%20Pi?action=show&redirect=FreeBSD%2Farm%2FRaspberry+Pi#Pre-Built_Images|pre-built images]] are available for all major versions of the Raspberry Pi. Just keep in mind that it isn't possible to upgrade the release in-place. | `dd` the image onto your device, and the rest will explain itself. |
Line 17: | Line 17: |
`dd` the image onto your device, and the rest will explain itself. | ---- |
Line 21: | Line 21: |
---- |
|
Line 25: | Line 23: |
=== Software Installation === | |
Line 27: | Line 24: |
Official repositories are managed with the '''pkg''' package manager. To update installed packages, use `pkg update && pkg upgrade`. To add a package such as HAProxy, use `pkg install haproxy`. | |
Line 29: | Line 25: |
The '''ports''' project maintains a hierarchy of Makefiles to compile a much larger variety of packages on FreeBSD. To initialize the ports hierarchy locally to `/usr/ports`, run `portsnap fetch && portsnap extract`. Subsequently, to update the hierarchy, run `portsnap fetch && portsnap update`. | === Operating System Updates === |
Line 31: | Line 27: |
Alternatively, clone the Subversion repository of the ports project. | Updates to the operating system are handled by `freebsd-update(8)`. Each minor and major version release will have it's own upgrade notes. The general process is: |
Line 34: | Line 32: |
pkg install subversion svn checkout https://svn.FreeBSD.org/ports/head /usr/ports |
# run current version updates freebsd-update fetch freebsd-update install # fetch new version updates freebsd-update upgrade -r MAJOR.MINOR-RELEASE freebsd-update install # reboot shutdown -r now |
Line 38: | Line 44: |
Use `pkg version -l "<"` to list ports packages that are out of date. | === Software === See [[BSD/FreeBSD/Packaging|here]] for details on software and packages. |
FreeBSD
FreeBSD is one of the most popular branches of the BSD project, and one of the oldest open-source branches. It emphasizes security through design and offers a featureful packaging toolchain.
Installation
Grab an image from the official repositories. You likely will want either the -memstick.img or the mini-memstick.img images. The former is larger, the latter requires an internet conection during installation.
dd the image onto your device, and the rest will explain itself.
Administration
Operating System Updates
Updates to the operating system are handled by freebsd-update(8).
Each minor and major version release will have it's own upgrade notes. The general process is:
# run current version updates freebsd-update fetch freebsd-update install # fetch new version updates freebsd-update upgrade -r MAJOR.MINOR-RELEASE freebsd-update install # reboot shutdown -r now
Software
See here for details on software and packages.
Services
FreeBSD uses BSD init for services. To enable SSH, edit /etc/rc.conf with:
sshd_enable="YES"
This enables the service. To start it immediately, run service sshd start.