⇤ ← Revision 1 as of 2020-07-10 21:43:20
Size: 1237
Comment:
|
Size: 2011
Comment:
|
Deletions are marked like this. | Additions are marked like this. |
Line 3: | Line 3: |
FreeBSD is one of the most popular branches of the BSD project, and one of the oldest open-source branches. It emphasizes security through design and offers a featureful packaging toolchain. | '''FreeBSD''' is one of the most popular branches of the BSD project, and one of the oldest open-source branches. It emphasizes security through design and offers a featureful packaging toolchain. |
Line 28: | Line 28: |
The '''ports''' project maintains a hierarchy of Makefiles to compile a much larger variety of packages on FreeBSD. To initialize the ports hierarchy locally to `/usr/ports`, run `portsnap fetch && portsnap extract`. Subsequently, to update the hierarchy, run `portsnap fetch && portsnap update`. Alternatively, clone the Subversion repository of the ports project. {{{ pkg install subversion svn checkout https://svn.FreeBSD.org/ports/head /usr/ports }}} Use `pkg version -l "<"` to list ports packages that are out of date. === Services === FreeBSD uses '''BSD init''' for services. To enable SSH, edit `/etc/rc.conf` with: {{{ sshd_enable="YES" }}} This enables the service. To start it immediately, run `service sshd start`. |
FreeBSD Setup
FreeBSD is one of the most popular branches of the BSD project, and one of the oldest open-source branches. It emphasizes security through design and offers a featureful packaging toolchain.
Installation
Grab an image from the official repositories. You likely will want either the -memstick.img or the mini-memstick.img images. The former is larger, the latter requires an internet conection during installation.
While ARM's aarch64 (a.k.a. armv8) is not a Tier 1 supported platform, pre-built images are available for all major versions of the Raspberry Pi. Just keep in mind that it isn't possible to upgrade the release in-place.
dd the image onto your device, and the rest will explain itself.
Administration
Software Installation
Official repositories are managed with the pkg package manager. To update installed packages, use pkg update && pkg upgrade. To add a package such as HAProxy, use pkg install haproxy.
The ports project maintains a hierarchy of Makefiles to compile a much larger variety of packages on FreeBSD. To initialize the ports hierarchy locally to /usr/ports, run portsnap fetch && portsnap extract. Subsequently, to update the hierarchy, run portsnap fetch && portsnap update.
Alternatively, clone the Subversion repository of the ports project.
pkg install subversion svn checkout https://svn.FreeBSD.org/ports/head /usr/ports
Use pkg version -l "<" to list ports packages that are out of date.
Services
FreeBSD uses BSD init for services. To enable SSH, edit /etc/rc.conf with:
sshd_enable="YES"
This enables the service. To start it immediately, run service sshd start.